Sales Web are experiencing issues by Cloudflare

Incident Report for CoverManager

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:44 CET

Monitoring

The incident continues intermittently. We are monitoring to assess its correction.
Posted Nov 18, 2025 - 16:02 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 14:32 CET
This incident affected: Experiences.