DB Problem

Incident Report for CoverManager

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 14:01 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 04, 2026 - 13:46 CET

Investigating

We are currently investigating this issue.
Posted Mar 04, 2026 - 13:41 CET
This incident affected: API and Saas.