Google Maps Integration

Incident Report for CoverManager

Resolved

The incident has been resolved. Google has fixed the issue.
Posted Nov 13, 2025 - 11:40 CET

Update

We are still waiting for Google to fix the issue.
Posted Nov 13, 2025 - 11:36 CET

Identified

Integration with Google is down due to a Google error.
Posted Nov 13, 2025 - 11:07 CET
This incident affected: API.